Jump to content


Getting an "Insecure Connection" warning for Exisle? No worry

Details in this thread

Small Windows 7 Problem... Asking For Help


  • Please log in to reply
7 replies to this topic

#1 Yankee White

Yankee White
  • Just Washed Ashore
  • 45 posts

Posted 11 December 2015 - 08:58 AM

Hiya. I'm running W7 on a Toshiba laptop. About two months ago, Explorer stopped showing certain icons for open stuff on the taskbar. Shown below is a picture of the problem.

Posted Image

What you see if FireFox open, and the icon is just fine. The other blank icon is a folder open, and that's all it ever shows now for open folders and if I'm running VLC. I can't think of any other problem children, but I'm sure there are others.

I googled the problem the other day, deciding to fix it once and for all, and I got some advice to delete the desktopicon.db (or something like that) and reboot. I did that but no joy. Can any of the tech minded people here give me any advice? It's no big deal, but it's pretty annoying to me.
The Bird of Paradise comes only to an open hand.

#2 Yankee White

Yankee White
  • Just Washed Ashore
  • 45 posts

Posted 13 December 2015 - 08:53 PM

Anyone?

Bueller?

Bueller?

:D
The Bird of Paradise comes only to an open hand.

#3 Orpheus

Orpheus

    I'm not the boss of you!

  • Administrator
  • 17,754 posts

Posted 13 December 2015 - 09:45 PM

1. Press Ctrl-Shift-Escape to get the task manager.

2. In the Processes tab, click on explorer.exe and click End Process.
You'll get a confirmation dialog. Click "End Process" to confirm.

3. From the File menu (still in the task manager), choose New Task (Run...).

4. Copy/paste/enter the following command in the run box:
 cmd /c del %userprofile%\AppData\Local\IconCache.db /a
(if the exact command above doesn't work, replace %userprofile% with c:\Users\<youruserprofilename>)

5. Open the Run box again with File --> New Task (Run...). This time, enter this command:
explorer.exe

Let me know if that works. I have other ideas.

Edited by Orpheus, 14 December 2015 - 02:01 PM.
fixed chopped-off line in instructions


#4 Yankee White

Yankee White
  • Just Washed Ashore
  • 45 posts

Posted 14 December 2015 - 06:16 AM

Thanks, Orpheus! I'll give it a try later this morning and report the results.
The Bird of Paradise comes only to an open hand.

#5 Orpheus

Orpheus

    I'm not the boss of you!

  • Administrator
  • 17,754 posts

Posted 14 December 2015 - 01:56 PM

It looks like something went a little screwy with the formatting of my post above. I've corrected it.

Also, I assumed your Windows is installed on drive C: (99.99% of installs are)

#6 Yankee White

Yankee White
  • Just Washed Ashore
  • 45 posts

Posted 14 December 2015 - 04:29 PM

No joy. That's a variation of something I tried before where I deleted the IconCache.db , except before I didn't kill explorer.exe first.
The Bird of Paradise comes only to an open hand.

#7 Orpheus

Orpheus

    I'm not the boss of you!

  • Administrator
  • 17,754 posts

Posted 14 December 2015 - 08:27 PM

Yeah, you must stop explorer.exe first because it loads IconCache.db into RAM/tempfile when it runs, and may writes that version back when it closes. (I assume you did it with instructions as currently posted. One line in the original post was a bit garbled).

You can also try resizing your desktop (which forces a rebuild of many graphics/icon things) and changing it back in a few minutes.

Also, laptops often have model/line-specific graphics quirks, which can get jammed up by some Windows Update. They usually release an updated driver in fairly short order. Make sure you're running the latest version drivers (esp graphics) for your laptop. Some Toshiba laptops have Invidia graphics chips, which were known to have that problem (fixed in latest driver)


rightclick Taskbar > Properties > Taskbar buttons
a) uncheck "Use Small icons" (or re-check it, if already unchecked)
b) change "Always Combine" to "Combine when taskbar is full" (or vice versa)

a) and b) are two different issues, but you might as well try them both, while you're there.

You didn't mention how you were invoking the program. If you use a pinned icon to invoke the program, that opens up several more avenues to explore (Microsoft KnowledgeBase notes one solution -- and probably more, but I didn't look in any depth)

#8 Yankee White

Yankee White
  • Just Washed Ashore
  • 45 posts

Posted 14 December 2015 - 09:11 PM

Bingo! Changing to small icons and combining them did the trick!

Thanks, Orpheus! You solved a really annoying problem. I'll dance at your wedding, or your next wedding, or your funeral or whatever applies! :D
The Bird of Paradise comes only to an open hand.


0 user(s) are browsing this forum

0 members, 0 guests, 0 anonymous users